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Downloading a ROBOTC Sample Program

You will need:
•	 1 VEX Cortex Microcontroller with one 7.2V Robot Battery
•	 2 Motor Modules connected to MOTOR ports 2 and 3 on the VEX Cortex
•	 1 VEXnet Remote Control with 6 AAA Batteries
•	 2 VEXnet USB Adapter Keys
•	 A computer with ROBOTC for Cortex 2.3 BETA or higher installed
•	 1 VEX Programming Kit
•	 1 USB A-to-A Cable

This document is a guide for downloading and running programs on the VEX Cortex using 
ROBOTC for Cortex 2.3 BETA. It is broken into four sections: Prerequisites, Downloading Using 
USB Only, Downloading Using VEXnet or USB, and Troubleshooting.

Prerequisites
The Cortex, VEXnet Remote Control, and your computer require some configuration before 
you are able to program your robot using ROBOTC. This guide assumes that you have already 
used ROBOTC to update the firmware on the VEXnet Remote Control, and both the Master and 
ROBOTC firmware on the Cortex.
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1.	 Leaving the POWER switch in the OFF position, connect your Cortex to the computer using the USB 
A-to-A cable. Once the cable is attached, move the POWER switch to the ON position.

Option 1. Downloading Using USB Only
When programming the VEX Cortex, a USB A-to-A cable can be used to directly connect your 
computer to the Cortex. This method instructs the robot to immediately run the program stored in 
memory when it is powered on, and skips the intial VEXnet link setup. Downloading using USB only is 
effective for writing and testing autonomous-only programs that do no require a VEXnet link. 

2.	 Specify how your Cortex is connected to the computer in the ROBOTC Preferences.

1a.	 Connect the Cortex to your PC
Use the USB A-to-A cable to 
connect your Cortex to your PC.

1b.	 Turn the Cortex ON
Make sure a 7.2V Robot battery is 
connected and move the POWER 
switch on the Cortex to ON.

2a.	 Detailed Preferences...
Go to View > Preferences 
and select Detailed 
Preferences...

Downloading a ROBOTC Sample Program (cont.)
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3.	 The ROBOTC Firmware enables you to download ROBOTC programs to your robot and utilize 
the various debug windows. Go to Robot > Download Firmware and select Download using 
Default File to download the ROBOTC Firmware to your robot.

2c.	 Communication Port
To program directly over the 
USB A-to-A cable, select the 
option that specifys the USB 
Wired Cable. Press OK to 
finalize your setting.

2b.	 Platform Tab
	 	 Make sure that the Platform 

tab is selected on the ROBOTC 
Preferences window.

3. 	Download Progress
A Download Progress window will appear and begin the download process. 
When the window closes, the firmware download is complete. 
 
Note:  You only need to download the ROBOTC Firmware once. 
Switching programs or download methods does not require a re-download. 

Downloading a ROBOTC Sample Program (cont.)
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4.	Go to File and select Open Sample Program to open a ROBOTC sample program.

4. 	Open a Sample Program
When the Open dialogue box appears, 
open the Basic Movement folder and 
select Moving Forward.c.

5.	 Specify the Download Using USB Only as the VEX Cortex Download Method. ROBOTC will remember 
your choice, so you do not need to select it every time you download a program. 

Downloading a ROBOTC Sample Program (cont.)
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6.	Go to Robot and select Compile and Download Program to download the 
sample program to the robot. 

6. 	Download Progress
A Download Progress window will appear and begin the download process. 
When the window closes, the program download is complete. 

In addition to ROBOTC, the VEX Cortex also remembers your Download Method 
setting. If this is the first time that you have chosen “Download Using USB Only”, or if 
you just switched from “Download Using VEXnet USB” or “Download for Competition 
(VEXnet)”, you will need to completely power cycle your Cortex (unplug the USB 
cable, power the Cortex OFF and then ON) before the updated setting takes effect 
and the program runs immediately.

The process of power cycling your Cortex is required any time you switch the 
Download Method setting.

Important Information - Power Cycle the VEX Cortex

7.	 Run the program on your robot by pressing the Start button on the Program 
Debug window, or by power cycling the Cortex. 

7a.	 Program Debug window
	 	 The Program Debug window appears every 

time you download a ROBOTC program to 
your robot. Press the Start button to run the 
program.

		  Note:  Remember that you may need to 
power cycle your Cortex for the program to 
immediately run, if you are using Download 
Using USB Only the first time, or have just 
switched from another method.

Downloading a ROBOTC Sample Program (cont.)
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7b.	 Power Cycle the Cortex
	 	 You can also run the program by turning the 

Cortex OFF, and then ON. 

		  Note:  The USB cable provides some power to 
the Cortex, so it must be unplugged to fully turn 
the Cortex OFF. Closing the ROBOTC Program 
Debug window before unplugging the USB 
cable is recommended.

8.	Observe the sample program running on the robot. The motors plugged into MOTOR 
ports 2 and 3 should spin for 3 seconds, according to the ROBOTC program.

End of Section:  Option 1. Downloading Using USB Only 
In this section, you learned how to program your robot directly over the USB A-to-A cable. 
If you experienced issues with the process, make sure you’ve follwed every step, and then 
reference the troubleshooting section below.

Downloading a ROBOTC Sample Program (cont.)
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1.	Use the VEX Programming Kit to connect a USB port on your computer to the PROGRAM port on your 
VEXnet Remote Control. Turn both the Cortex and VEXnet Remote Control ON and allow them to sync.

Option 2. Downloading Using VEXnet or USB
When using the VEXnet link to communicate between your computer and the Cortex, downloading 
firmware, downloading programs, and using the ROBOTC real-time debugger all work wirelessly. This 
guide assumes you have already configured the VEXnet link between your Cortex and VEXnet Remote 
Control. Programs downloaded using this method will not run until a VEXnet link has been established 
or until 10 seconds have elapsed since the Cortex was powered on.

2.	 Specify how your Cortex is connected to the computer in the ROBOTC Preferences.

2a.	 Detailed Preferences...
Go to View > Preferences 
and select Detailed 
Preferences...

Downloading a ROBOTC Sample Program (cont.)
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2c.	 Communication Port
ROBOTC uses the connection 
between your computer and 
the VEXnet Remote Control to 
take advantage of the VEXnet 
communication link. The 
VEXnet Remote Control acts 
as an intermediary between 
ROBOTC and your robot. 
Select the port that specifys the 
Prolific USB-to-Serial Comm 
Port and press OK to finalize 
your setting.

2b.	 Platform Tab
	 	 Make sure that the Platform 

tab is selected on the ROBOTC 
Preferences window.

3.	 The ROBOTC Firmware enables you to download ROBOTC programs to your robot and utilize 
the various debug windows. Go to Robot > Download Firmware and select Download using 
Default File to download the ROBOTC Firmware to your robot.

3. 	Download Progress
A Download Progress window will appear and begin the download process. 
When the window closes, the firmware download is complete. 
 
Note:  You only need to download the ROBOTC Firmware once. 
Switching programs or download methods does not require a re-download. 

Downloading a ROBOTC Sample Program (cont.)
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4.	Go to File and select Open Sample Program to open a ROBOTC Sample Program.

4. 	Open a Sample Program
When the Open dialogue box appears, 
open the Basic Movement folder and 
select Moving Forward.c.

5.	 Specify the Download Using VEXnet or USB as the VEX Cortex Download Method. ROBOTC will 
remember your choice, so you do not need to select it every time you download a program. 

Downloading a ROBOTC Sample Program (cont.)
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6.	Go to Robot and select Compile and Download Program to download the 
sample program to the robot. 

6. 	Download Progress
A Download Progress window will appear and begin the download process. 
When the window closes, the program download is complete. 

In addition to ROBOTC, the VEX Cortex also remembers your Download Method 
setting. If this is the first time that you have chosen “Download Using VEXnet or 
USB”, or if you just switched from “Download Using USB only” or “Download for 
Competition (VEXnet)”, you will need to completely power cycle your Cortex (power 
the Cortex OFF and then ON) before the updated setting takes effect and the 
program looks for the VEXnet link before running.

The process of power cycling your Cortex is required any time you switch the 
Download Method setting.

Important Information - Power Cycle the VEX Cortex

7.	 Run the program on your robot by pressing the Start button on the Program Debug window, 
or by power cycling the Cortex. 

7a.	 Program Debug window
	 	 The Program Debug window appears every 

time you download a ROBOTC program to 
your robot. Press the Start button to run the 
program.

		  Note:  Remember that you may need to power 
cycle your Cortex for the program to establish 
a VEXnet link before running, if you are using 
Download Using VEXnet or USB the first time, 
or have just switched from another method.

Downloading a ROBOTC Sample Program (cont.)
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7b.	 Power Cycle the Cortex
	 	 You can also run the program by turning the 

Cortex OFF, and then ON. 

		  Note:  The Cortex will not run the program 
until a VEXnet link has been established or 
at least 10 seconds have elapsed.  Closing 
the ROBOTC Program Debug window before 
turning off the Cortex is recommended.

8.	Observe the sample program running on the robot. The motors plugged into MOTOR 
ports 2 and 3 should spin for 3 seconds, according to the ROBOTC program.

End of Section:  Option2 . Downloading Using VEXnet or USB 
In this section, you learned how to program your robot wirelessly using VEXnet. 
If you experienced issues with the process, make sure you’ve follwed every step, 
and then reference the troubleshooting section below.

Downloading a ROBOTC Sample Program (cont.)
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Troubleshooting 
 
Problem:  Communication using the USB A-to-A cable between ROBOTC and the Cortex is 
very slow, or not working.

Resolution:  Verify each of the following options, and re-test your communication link before 
moving on:

Is the USB A-to-A cable connecting the computer to your Cortex? The USB cable will provide 	
some power to the Cortex, powering some of its status lights. If not, try rebooting your system.

Is your robot also connected to and powered on by a charged battery? 

Did you have the robot powered on before you connected it to the computer using the USB 
A-to-A cable? The robot must first be connected to the computer using the USB A-to-A cable, 
and then powered on with the battery.

Is VEX 2.0 Cortex selected as the Platform Type in ROBOTC?

 
Have you selected the correct Communication Port in the ROBOTC Preferences?

 
 
Have you downloaded the ROBOTC Firmware to the Cortex?

Downloading a ROBOTC Sample Program (cont.)
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Troubleshooting 
 
If you’ve verified all of the previous options with no success, you can enable “Message Tracing” 
to put ROBOTC into a persistent communication mode. 

Begin by going to Window > Menu Level and selecting Super User to switch your viewing 
preferences to the Super User level.

Then go to View > Preferences and select Detailed Preferences...

On the Internal tab, select Messages under Message Tracing to put ROBOTC into its persistent 
communication mode. Press OK to verify your setting.

Now when you download a program, ROBOTC will also open the Message Log with the 
Cortex in a new tab. You can switch back and forth between your program and the Message 
Log by clicking on the desired tab.

Downloading a ROBOTC Sample Program (cont.)
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